Opened 17 months ago

Closed 4 months ago

#8721 defect closed duplicate (duplicate)

Conch only works with diffie-hellman-group-exchange-sha256

Reported by: the0id Owned by:
Priority: normal Milestone:
Component: conch Keywords:
Cc: Branch:
Author:

Description

It appears that using Conch will only work if the server KexAlgorithm is diffie-hellman-group-exchange-sha256.

I have not done through testing on this, but on my system I can only connect to an SSH server if that server is configured to use diffie-hellman-group-exchange-sha256.

Group exchange 1, group1-sha1, group14-sha1 all seem to fail when the client (Conch), sends the New Keys message, where the OpenSSH server then closes the connection.

Change History (3)

comment:1 Changed 16 months ago by the0id

Component: coreconch

comment:2 Changed 15 months ago by the0id

It looks like the problem is the SSH_MSG_NEWKEYS (H)MAC is bad and the server is rejecting it.

I haven't found out why yet, and will work on this a little more if I can, but this seems to be where the problem is.

comment:3 Changed 4 months ago by the0id

Resolution: duplicate
Status: newclosed

This is a duplicate of #8258

Note: See TracTickets for help on using tickets.