#8670 enhancement closed duplicate (duplicate)

test_pb fails on Python3

Reported by: Abhishek Choudhary Owned by:
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Branch:
Author:

Description

test_pb in twisted.test fails on Python 3

python3 bin/trial twisted/test/test_pb.py
twisted/test/test_pb
  py ...                                                                [ERROR]

===============================================================================
[ERROR]
Traceback (most recent call last):
  File "/home/ac/Twisted2/twisted/trial/runner.py", line 781, in loadByName
    return self.suiteFactory([self.findByName(name, recurse=recurse)])
  File "/home/ac/Twisted2/twisted/trial/runner.py", line 682, in findByName
    return self.loadFile(_name, recurse=recurse)
  File "/home/ac/Twisted2/twisted/trial/runner.py", line 652, in loadFile
    module = SourceFileLoader(name, fileName).load_module()
  File "<frozen importlib._bootstrap_external>", line 385, in _check_name_wrapper
    
  File "<frozen importlib._bootstrap_external>", line 806, in load_module
    
  File "<frozen importlib._bootstrap_external>", line 665, in load_module
    
  File "<frozen importlib._bootstrap>", line 268, in _load_module_shim
    
  File "<frozen importlib._bootstrap>", line 693, in _load
    
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
    
  File "<frozen importlib._bootstrap_external>", line 662, in exec_module
    
  File "<frozen importlib._bootstrap>", line 222, in _call_with_frames_removed
    
  File "twisted/test/test_pb.py", line 16, in <module>
    from cStringIO import StringIO
builtins.ImportError: No module named 'cStringIO'

twisted/test/test_pb.py
-------------------------------------------------------------------------------
Ran 1 tests in 0.065s


Change History (1)

comment:1 Changed 14 months ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of 7598

Note: See TracTickets for help on using tickets.