Opened 17 months ago

Closed 5 months ago

#8608 defect closed duplicate (duplicate)

Close files in twisted.news.tap

Reported by: mark williams Owned by:
Priority: normal Milestone: PyPy-support
Component: core Keywords: files news
Cc: Branch:
Author:

Description

Naively grepping for files that are opened and read or written without being closed:

git grep '[^\.]open([^)]\+)\.[^c]' -- '*.py' | grep -v 'with open'

...turned up several places in twisted.news.tap that leak open files. These should be explicitly closed.

Change History (2)

comment:1 Changed 17 months ago by mark williams

I can't mark this as a dupe of #8573 because of the spam filter :(

comment:2 Changed 5 months ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of ticket:8573

Note: See TracTickets for help on using tickets.