Opened 13 years ago

Closed 8 years ago

#859 defect closed duplicate (duplicate)

what the heck is wrong with buildbot running the SQLite tests

Reported by: Glyph Owned by:
Priority: low Milestone:
Component: core Keywords:
Cc: Glyph, Cory Dodt, Jean-Paul Calderone, Dave Peticolas Branch:
Author:

Description


Change History (8)

comment:1 Changed 13 years ago by Glyph

twisted.test.test_adbapi.SQLiteADBAPITestCase is failing on the buildbot, in
various permutations, but only sometimes.  please discover why so we stop
getting lots of red.

comment:2 Changed 13 years ago by Dave Peticolas

I can't duplicate this on my own machine, no matter how many times
I run. I've reduced the number of test iterations for gadfly & sqlite,
but that probably won't eliminate the problem. I suppose you can just
have the test skipped.

comment:3 Changed 13 years ago by Jean-Paul Calderone

Some of these failures have been fixed.  I think the remaining are all just load
related.

Is it possible to rewrite these tests to use a more incremental timeout scheme?
 As long as some progress is being made, we shouldn't fail the test.

comment:4 Changed 11 years ago by Cory Dodt

Component: conch
Owner: changed from Cory Dodt to Jean-Paul Calderone

Sorry JP but I don't know who owns this and you touched it last. I just know for sure it shouldn't be me. :-)

comment:5 Changed 11 years ago by Jonathan Lange

Component: conchcore

comment:6 Changed 10 years ago by Jean-Paul Calderone

Priority: highlow

No failures in this area in a while. Any unit test which uses a thread is probably prone to spurious failures. We should really do something about this at some point. However, I have no particular motivation to work on this at the moment. If it comes up in the future, I might, but if someone else cares about this, they should steal it from me and work on it themselves.

comment:7 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Unfortunately the mode of failure was not described. However, I suspect this is likely a duplicate of #784.

comment:8 Changed 7 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.