Opened 2 years ago

Closed 16 months ago

#8121 enhancement closed duplicate (duplicate)

Port twisted.protocols.htb to Python 3

Reported by: Thijs Triemstra Owned by: Thijs Triemstra
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Branch: branches/htb-py3-8121
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl

Description

Port twisted.protocols.htb to Python 3.

Attachments (2)

8121.patch (4.1 KB) - added by Thijs Triemstra 2 years ago.
8121-2.patch (674 bytes) - added by Thijs Triemstra 2 years ago.
also include pcp

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by Thijs Triemstra

Attachment: 8121.patch added

comment:1 Changed 2 years ago by Thijs Triemstra

Keywords: review added

With attached patch the tests pass on Python 3.4.

comment:2 Changed 2 years ago by hawkowl

Author: hawkowl
Branch: branches/htb-py3-8121

(In [46301]) Branching to htb-py3-8121.

Changed 2 years ago by Thijs Triemstra

Attachment: 8121-2.patch added

also include pcp

comment:3 Changed 2 years ago by Thijs Triemstra

Forgot to include the pcp protocol that was also ported. Attached patch was made against the branch for this ticket.

comment:4 Changed 2 years ago by hawkowl

(In [46314]) Applying patch 2 from thijs, refs #8121

comment:5 Changed 2 years ago by hawkowl

Keywords: review removed
Owner: set to Thijs Triemstra

Hi Thijs, thanks for the patch.

In pcp.py and test_pcp.py, the producer/consumer operates on str, not bytestrings. These should be updated to work on binary data, as str on Python 3 is Unicode. Please see https://twistedmatrix.com/trac/wiki/Plan/Python3 for some more of the intricacies with this.

Please fix this and put it back up for review. Thanks again!

comment:6 Changed 16 months ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of 8716

Note: See TracTickets for help on using tickets.