Opened 2 years ago

Closed 18 months ago

#8018 defect closed duplicate (duplicate)

Port twisted.internet._win32stdio to Python 3

Reported by: Doadin Owned by: hawkowl
Priority: high Milestone: Python-3.x
Component: core Keywords:
Cc: Branch:
Author:

Description


Change History (12)

comment:1 Changed 2 years ago by Adi Roiban

Hi Doadin,

Thanks for your patches.

Please note that the patches should be submitted as a single file together with test

More info about the Twisted dev process can be found here http://twistedmatrix.com/trac/wiki/TwistedDevelopment

See here for a patch which ports some code to py3

https://github.com/twisted/twisted/commit/59daefaa2a5363acfa9b3b049623458402529eae

Note that the ported modules and tests should be recorded in the dist3.py file.

Please let us know if you need any help with the patch.

Thanks!

comment:2 Changed 2 years ago by Doadin

I updated the patch to be all in one and added a missing import. I think i might need help or someone to review.

comment:3 Changed 2 years ago by Adi Roiban

This ticket needs a better description.

Why you need to update those file for python3 compatiblity?

What is the goal of this update?

What was not previously working and will work after this update?

This questions need to be answered in the description of this ticket.

The new functionality should be advertised in a news file fragment, submitted in the same path, so that the release notes will contain a note about this change.

More info about the news file can be found here http://twistedmatrix.com/trac/wiki/ReviewProcess#Newsfiles

comment:4 Changed 2 years ago by Doadin

Summary: Update _win32stdio.py and _pollingfile.py for zope.interface python3 compatibilityUpdate _win32stdio to fix raise TypeError('Class advice impossible in Python3') from zope.interface

comment:5 Changed 2 years ago by Doadin

Priority: normalhigh
Type: enhancementregression

comment:6 Changed 2 years ago by hawkowl

Owner: set to hawkowl
Summary: Update _win32stdio to fix raise TypeError('Class advice impossible in Python3') from zope.interfacePort twisted.internet._win32stdio to Python 3
Type: regressiondefect

This isn't a regression (we've never supported Py3 on Windows).

Once we get a Python 3 builder on Windows we can put run the tests and move this forward (hopefully next week?).

I'll assign it to me, as it's blocked on me getting that going.

comment:7 Changed 20 months ago by Doadin

Any update on this? Its been 7 months.

comment:8 Changed 20 months ago by hawkowl

@Doadin I made some progress on this the other day -- see https://twistedmatrix.com/trac/ticket/8025 and the precursor https://tm.tl/#8266 for two tickets that would solve this in due course. If you have some spare time, a review on #8266 would be very appreciated :)

comment:9 Changed 18 months ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of 8291

Note: See TracTickets for help on using tickets.