Opened 2 years ago

Closed 17 months ago

#7995 enhancement closed duplicate (duplicate)

setup.py on Python 3 should have optional dependencies which work on Py3

Reported by: hawkowl Owned by: hawkowl
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Branch: branches/optional-deps-7995-2
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl

Description

We should be able to do pip install twisted[tls] etc on Python 3 and get the dependencies.

Change History (5)

comment:1 Changed 2 years ago by hawkowl

Author: hawkowl
Branch: branches/optional-deps-7995

(In [46209]) Branching to optional-deps-7995.

comment:2 Changed 21 months ago by hawkowl

Branch: branches/optional-deps-7995branches/optional-deps-7995-2

(In [47142]) Branching to optional-deps-7995-2.

comment:3 Changed 21 months ago by hawkowl

Keywords: review added

I'm happy with this. Builders spun, please review.

(the twistedchecker failures are spurious)

comment:4 Changed 21 months ago by Adi Roiban

Keywords: review removed
Owner: set to hawkowl

Looks good. Thanks.

Please merge.

comment:5 Changed 17 months ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of 8606

Note: See TracTickets for help on using tickets.