Opened 13 years ago

Last modified 13 years ago

#799 defect closed fixed (fixed)

Intermittent twisted.trial.test.test_util.TestMktemp failure

Reported by: Jean-Paul Calderone Owned by:
Priority: high Milestone:
Component: trial Keywords:
Cc: radix, Jean-Paul Calderone, spiv, slyphon Branch:
Author:

Description


Change History (5)

comment:1 Changed 13 years ago by Jean-Paul Calderone

===============================================================================
[ERROR]: testMktmp (twisted.trial.test.test_util.TestMktemp)


  File "/home/exarkun/projects/python/Twisted/trunk/twisted/internet/defer.py",
line 117, in maybeDeferred
    result = f(*args, **kw)
  File
"/home/exarkun/projects/python/Twisted/trunk/twisted/trial/test/test_util.py",
line 131, in testMktmp
    tmp = self.mktemp()
  File "/home/exarkun/projects/python/Twisted/trunk/twisted/trial/unittest.py",
line 448, in mktemp
    os.makedirs(base)
  File "/usr/lib/python2.3/os.py", line 153, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.3/os.py", line 153, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.3/os.py", line 154, in makedirs
    mkdir(name, mode)
exceptions.OSError: [Errno 2] No such file or directory:
'twisted.trial.test.test_util'
-------------------------------------------------------------------------------

comment:2 Changed 13 years ago by radix

where? when? what environment?

comment:3 Changed 13 years ago by spiv

I can't reproduce this with "trial -u twisted.trial.test.test_util.TestMktemp".
 Assigning back to exarkun for more info.

comment:4 Changed 13 years ago by Jean-Paul Calderone

Seen only on buildbot once.  Likelyhood of reproduction is slim.  Closing until
such time as this happens.

comment:5 Changed 7 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.