Opened 2 years ago

Closed 17 months ago

#7966 defect closed duplicate (duplicate)

ad-hoc version parsing in service identity module selection doesn't work with in-development pyOpenSSL

Reported by: Glyph Owned by: Glyph
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch: version-parsing-7966
branch-diff, diff-cov, branch-cov, buildbot
Author: glyph

Description

As discovered on https://github.com/twisted/treq/pull/97 sometimes the components of the version contain a .dev0, which causes an exception.

Change History (6)

comment:1 Changed 2 years ago by Glyph

Type: enhancementdefect

comment:2 Changed 2 years ago by Glyph

Author: glyph
Branch: branches/version-parsing-7966

(In [45218]) Branching to version-parsing-7966.

comment:3 Changed 2 years ago by Glyph

Keywords: review added

Builders appear pretty happy, and it seems to address the issue.

comment:4 Changed 2 years ago by Adi Roiban

Keywords: review removed
Owner: set to Glyph

Hi,

There is no news file.

__exit__ has a copy/pasted docstring... does it need a docstring ? The class's docstring is pretty clear.

It looks like the code only cares for the first 2 parts of a version scheme. The test and code should not talk about dev0 patch release number but just inform that only major and minor are considered.

I don't understand the test_inDevelopmentPyOpenSSL test ... the act part of the test don't match with the docstring.... or if it does, it does it in a very strange way.

Please check my comments and merge if you think that it is ok.

Thanks!

comment:5 Changed 17 months ago by Glyph

Branch: branches/version-parsing-7966version-parsing-7966

comment:6 Changed 17 months ago by Glyph

Resolution: duplicate
Status: newclosed

#8056 was a duplicate of this and it's fixed.

Note: See TracTickets for help on using tickets.