Opened 3 years ago

Closed 13 months ago

#7861 enhancement closed duplicate (duplicate)

twisted.conch.endpoints connection helpers should be public.

Reported by: Tom Prince Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

SSHCommandClientEndpoint.existingConnection expects an existing connection, but there is no easy way to do that, using public interfaces. The example code works around this by running a long-running process in one connection, and then reusing that connection.

But _NewConnectionHelper does implement this. (Although the current interface may not be right.

Change History (1)

comment:1 Changed 13 months ago by Tom Prince

Resolution: duplicate
Status: newclosed

This is a duplicate of #6414.

Note: See TracTickets for help on using tickets.