Opened 3 years ago

Closed 2 years ago

#7816 enhancement closed duplicate (duplicate)

Port twisted.application.service on py3 for trial

Reported by: Adi Roiban Owned by: mesozoic
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Branch: branches/py3-application-service-7816
branch-diff, diff-cov, branch-cov, buildbot
Author:

Description (last modified by hawkowl)

Duplicate of #6916

Change History (4)

comment:1 Changed 3 years ago by mesozoic

Owner: changed from Adi Roiban to mesozoic
Status: newassigned

I thought I could get through this tonight, but I've gotta walk away and get some rest. Getting twisted.test.test_application to pass under Python 3 involved more mucking around than I thought it would. The branch is up-to-date.

I'm a bit stuck on this test failure:

$ python admin/run-python3-tests twisted.test.test_application.LoadingTests.test_simpleStoreAndLoad
test_simpleStoreAndLoad (twisted.test.test_application.LoadingTests)
test_simpleStoreAndLoad ... ERROR

======================================================================
ERROR: test_simpleStoreAndLoad (twisted.test.test_application.LoadingTests)
test_simpleStoreAndLoad
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/internet/defer.py", line 150, in maybeDeferred
    result = f(*args, **kw)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/internet/utils.py", line 201, in runWithWarningsSuppressed
    reraise(exc_info[1], exc_info[2])
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/python/compat.py", line 374, in reraise
    raise exception.with_traceback(traceback)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/internet/utils.py", line 197, in runWithWarningsSuppressed
    result = f(*a, **kw)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/test/test_application.py", line 232, in test_simpleStoreAndLoad
    p.save()
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/persisted/sob.py", line 124, in save
    self._saveTemp(filename, passphrase, dumpFunc)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/persisted/sob.py", line 95, in _saveTemp
    dumpFunc(self.original, f)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/persisted/aot.py", line 463, in jellyToSource
    aot = jellyToAOT(obj)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/persisted/aot.py", line 454, in jellyToAOT
    return AOTJellier().jelly(obj)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/persisted/aot.py", line 566, in jelly
    ao = self.jellyToAO(obj)
  File "/Users/mesozoic/Development/ext/twisted/twisted/twisted/persisted/aot.py", line 559, in jellyToAO
    raise TypeError("Unsupported type: %s" % objType.__name__)
TypeError: Unsupported type: Componentized

----------------------------------------------------------------------
Ran 1 test in 0.007s

FAILED (errors=1)

...and can't tell if that's because twisted.persisted needs more work, or if it's a regression I've introduced somewhere, or what. But I'll take another look later this week.

comment:2 Changed 3 years ago by mesozoic

Branch: branches/py3-application-service-7816

comment:3 Changed 3 years ago by mesozoic

This ticket is waiting on #7827 (porting twisted.persisted.styles)

comment:4 Changed 2 years ago by hawkowl

Description: modified (diff)
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.