Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7756 defect closed duplicate (duplicate)

test_ipv6AcceptAddress spurious failure

Reported by: Adi Roiban Owned by: Adi Roiban
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description (last modified by Adi Roiban)

Here is the buildbot with error

https://buildbot.twistedmatrix.com/builders/winxp32-py2.7/builds/4031

[ERROR]
Traceback (most recent call last):
  File "C:\buildslave\twisted\winxp32-py2.7\Twisted\twisted\internet\test\test_iocp.py", line 97, in test_ipv6AcceptAddress
    self._acceptAddressTest(AF_INET6, '::1')
  File "C:\buildslave\twisted\winxp32-py2.7\Twisted\twisted\internet\test\test_iocp.py", line 66, in _acceptAddressTest
    SOL_SOCKET, SO_UPDATE_ACCEPT_CONTEXT, pack('P', server.fileno()))
  File "c:\python27\lib\socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
socket.error: [Errno 10057] A request to send or receive data was disallowed because the socket is not connected and (when sending on a datagram socket using a sendto call) no address was supplied

twisted.internet.test.test_iocp.SupportTests.test_ipv6AcceptAddress

I see that it is also failing for select reactor... have no idea why.

I was not able to get iocpsupport on my WinXP VM...tried both MSI and Wheel files


I guess that the test is too fast and it does not wait for windows to set up the network part.

Change History (3)

comment:1 Changed 3 years ago by Adi Roiban

Description: modified (diff)
Owner: set to Adi Roiban

comment:2 Changed 3 years ago by Adi Roiban

Resolution: duplicate
Status: newclosed

This is a duplicate of #5356

comment:3 Changed 3 years ago by Jean-Paul Calderone

Please leave links in both directions on duplicates. Thanks.

Note: See TracTickets for help on using tickets.