Opened 3 years ago

Closed 3 years ago

#7720 enhancement closed duplicate (duplicate)

If available, include user name in combined log format

Reported by: free Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

The twisted.web.http.combinedLogFormatter function doesn't include the authenticated user in the string it generates.

From Apache's website [0]:

== Combined Log Format

Another commonly used format string is called the Combined Log Format. [...]

[...] The access log under this format will look like:

127.0.0.1 - frank [10/Oct/2000:13:55:36 -0700] "GET /apache_pb.gif HTTP/1.0" 200 2326 "http://www.example.com/start.html" "Mozilla/4.08 [en] (Win98; I ;Nav)" ==

Where "frank" is "the userid of the person requesting the document as determined by HTTP authentication".

[0] http://httpd.apache.org/docs/1.3/logs.html

Attachments (1)

log-http-user.patch (2.8 KB) - added by free 3 years ago.
Proposed bug fix

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by free

Attachment: log-http-user.patch added

Proposed bug fix

comment:1 Changed 3 years ago by free

Component: coreweb

comment:2 Changed 3 years ago by free

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #5501.

Note: See TracTickets for help on using tickets.