Opened 3 years ago

Closed 3 years ago

#7555 enhancement closed duplicate (duplicate)

twisted app will not start because of stale pidfile

Reported by: Karl Kuehn Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

I just had a buildbot slave not startup on a machine automatically because the twisted PID file had a fairly low-number id in it (112) that happened to have been used by another process after a crash.

I found the following message repeating in the error log file: Can't check status of PID 112 from pidfile /Users/teapot/buildslave/twistd.pid: Operation not permitted

I understand the purpose here, to avoid having multiple processes. But if you are getting errno.EPERM back from os.killit is likely that this is not your process, and so it is safe to assume the PID file is stale.

Change History (1)

comment:1 Changed 3 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Thanks for your interest in this area of Twisted.

This is a duplicate of either #3851 or perhaps even #5360.

Note: See TracTickets for help on using tickets.