Opened 3 years ago

Closed 3 weeks ago

#7554 defect closed duplicate (duplicate)

Bug in _sslverify's attempt to load constants from PyOpenSSL

Reported by: Alex Gaynor Owned by:
Priority: low Milestone:
Component: core Keywords: easy
Cc: Branch:
Author:

Description

There is a trailing space in the strings for OP_CIPHER_SERVER_PREFERENCE and OP_SINGLE_ECDH_USE here: https://github.com/twisted/twisted/blob/trunk/twisted/internet/_sslverify.py#L1212

Also, the OP_SINGLE_ECDH_USE constant is not exposed in any version of PyOpenSSL at all.

Change History (2)

comment:1 Changed 3 years ago by Glyph

Keywords: easy added
Priority: normallow

This should definitely be fixed but I'm going to call it "low priority" because the values are, as far as we know, correct ;-).

comment:2 Changed 3 weeks ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of ticket:8315

Note: See TracTickets for help on using tickets.