Opened 3 years ago

Closed 3 years ago

Last modified 13 months ago

#7551 defect closed duplicate (duplicate)

logger-logged exceptions and log-logged exceptions look different to observers ✓

Reported by: Glyph Owned by: Wilfredo Sánchez Vega
Priority: normal Milestone: New Logging System
Component: logger Keywords:
Cc: Branch: branches/log-remove-legacylogger-7639
branch-diff, diff-cov, branch-cov, buildbot
Author:

Description

When looking at #7545 and friends, I noticed that LegacyLogger.err doesn't set "log_failure" in its emitted message; instead, it simply sets the legacy-log-object failure key.

This means that tracebacks from old-style logging will not be properly relayed to a new-style observer. The reverse does work though, but only because LegacyLogObserverWrapper copies the new-style log_failure key to the old-style failure key before forwarding it on.

Change History (9)

comment:1 Changed 3 years ago by Glyph

Owner: set to Wilfredo Sánchez Vega
Type: enhancementdefect

comment:2 Changed 3 years ago by Glyph

Milestone: Twisted 14.1.0

Tagging this in the release because it's an unreleased public interface.

comment:3 Changed 3 years ago by Wilfredo Sánchez Vega

I'm proposing that we get rid of LegacyLogger (#7639), which would make this ticket no longer relevant.

comment:4 Changed 3 years ago by Wilfredo Sánchez Vega

Status: newassigned

comment:5 Changed 3 years ago by hawkowl

Milestone: Twisted 14.1.0New Logging System

comment:6 Changed 3 years ago by Wilfredo Sánchez Vega

Branch: branches/log-remove-legacylogger-7639
Keywords: review added
Resolution: duplicate
Status: assignedclosed

Calling this a duplicate of #7639.

comment:7 Changed 3 years ago by Wilfredo Sánchez Vega

Keywords: review removed

comment:8 Changed 3 years ago by Wilfredo Sánchez Vega

Summary: logger-logged exceptions and log-logged exceptions look different to observerslogger-logged exceptions and log-logged exceptions look different to observers ✓

comment:9 Changed 13 months ago by Wilfredo Sánchez Vega

Component: corelogger
Note: See TracTickets for help on using tickets.