Opened 3 years ago

Closed 3 years ago

#7535 release blocker: regression closed duplicate (duplicate)

twisted.test.test_sslverify.SelectVerifyImplementationTests.test_dependencyMissingWarning fails on Python 3.3

Reported by: Jean-Paul Calderone Owned by:
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Branch: branches/fix-ssl-dependency-warning-7535
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl

Description

Only if you have the necessary dependencies installed, otherwise it is skipped:

======================================================================
FAIL: test_dependencyMissingWarning (twisted.test.test_sslverify.SelectVerifyImplementationTests)
test_dependencyMissingWarning
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/buildslave/run/python-3.3-tests/Twisted/twisted/trial/_synctest.py", line 1308, in _run
    runWithWarningsSuppressed(suppress, method)
  File "/home/buildslave/run/python-3.3-tests/Twisted/twisted/python/util.py", line 1021, in runWithWarningsSuppressed
    return f(*args, **kwargs)
  File "/home/buildslave/run/python-3.3-tests/Twisted/twisted/test/test_sslverify.py", line 2434, in test_dependencyMissingWarning
    (expectedMessage, "", 0))
  File "/home/buildslave/run/python-3.3-tests/Twisted/twisted/trial/_synctest.py", line 447, in assertEqual
    % (msg, pformat(first), pformat(second)))
twisted.trial.unittest.FailTest: not equal:
a = ("You do not have a working installation of the service_identity module: 'import of 'service_identity' halted; None in sys.modules'.  Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  Without the service_identity module and a recent enough pyOpenSSL to support it, Twisted can perform only rudimentary TLS client hostname verification.  Many valid certificate/hostname mappings may be rejected.",
 '',
 0)
b = ("You do not have a working installation of the service_identity module: 'No module named service_identity'.  Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  Without the service_identity module and a recent enough pyOpenSSL to support it, Twisted can perform only rudimentary TLS client hostname verification.  Many valid certificate/hostname mappings may be rejected.",
 '',
 0)

Change History (2)

comment:1 Changed 3 years ago by hawkowl

Author: hawkowl
Branch: branches/fix-ssl-dependency-warning-7535

(In [42839]) Branching to fix-ssl-dependency-warning-7535.

comment:2 Changed 3 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #7355.

Note: See TracTickets for help on using tickets.