Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#7429 defect closed duplicate (duplicate)

failures of test_tls.py from -14.0.0

Reported by: I. Dleaney Owned by:
Priority: normal Milestone:
Component: core Keywords: tests
Cc: Hynek Schlawack Branch:
Author:

Description (last modified by Jean-Paul Calderone)

version of dev-libs/openssl; Installed versions: 1.0.1g

version of pyopenssl; Installed versions: 0.14.

from the run, the tests

  • test_dataReceivedThrows
  • test_resumeProducingThrows
  • test_resumeProducingAbortLater
  • test_resumeProducingAbort
  • test_fullWriteBufferAfterByteExchange

pass a number of times when called in file test_tcp.py They're run alphabetically of course. Once it hits test_tls.py from which they are apparently called again, we get

twisted.internet.test.test_tls
  AbortSSLConnectionTest_EPollReactor
    test_clientAbortsConnectionThenLosesConnection ...                     [OK]
    test_clientAbortsConnectionTwice ...                                   [OK]
    test_dataReceivedAbort ...                                             [OK]
    test_dataReceivedThrows ...                                          [FAIL]
    test_fullWriteBuffer ...                                               [OK]
    test_fullWriteBufferAfterByteExchange ... ^X^Z
[8]+  Stopped                 ebuild twisted-core-14.0.0.ebuild clean test.

If left these next four will take 'forever' to finally timeout and then [ERROR]: Here I just cut it with ctrl Z because I've done it a number of times already. They appear to indeed have their conflict sourced from openssl and or pyopenssl. While they are optional, they're also high profile and important.

Currently I have to sed them out of test_tcp.py in order to allow the suite to proceed.

Do you require anything further? I could allow them to timeout and error out but frankly I don't see the point.

Change History (8)

comment:1 Changed 4 years ago by Jean-Paul Calderone

Description: modified (diff)

comment:2 Changed 4 years ago by Jean-Paul Calderone

Milestone: Twisted 14.1.0

comment:3 Changed 4 years ago by Jean-Paul Calderone

I wonder if this is related to #7370.

comment:4 Changed 4 years ago by I. Dleaney

I'd say yes

comment:5 Changed 3 years ago by Hynek Schlawack

Cc: Hynek Schlawack added

comment:6 Changed 3 years ago by Hynek Schlawack

Commenting out the call to SSL_CTX_set_tmp_ecdh() fixes it so it is indeed related.

comment:7 Changed 3 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Now that I understand the problem, I'm confident marking this as a duplicate of #7370.

comment:8 Changed 2 years ago by hawkowl

Milestone: Twisted 14.1.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.