Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#7352 release blocker: regression closed fixed (fixed)

Fix the path to example scripts in twisted.names.test.test_examples

Reported by: Richard Wall Owned by: Roberto Polli
Priority: normal Milestone:
Component: names Keywords:
Cc: Roberto Polli Branch: branches/names-examples-path-7352
branch-diff, diff-cov, branch-cov, buildbot
Author: rwall

Description

I notice that the DNS example tests are being skipped since the latest re-arrangement of the documentation structure in r42144.

ames.test.test_examples.DnsServiceTests.test_shebang ... [SKIPPED]
twisted.names.test.test_examples.DnsServiceTests.test_usageConsistency ... [SKIPPED]
twisted.names.test.test_examples.DnsServiceTests.test_usageConsistencyOnError ... [SKIPPED]
twisted.names.test.test_examples.GetHostByNameTests.test_shebang ... [SKIPPED]
twisted.names.test.test_examples.GetHostByNameTests.test_usageConsistency ... [SKIPPED]
twisted.names.test.test_examples.GetHostByNameTests.test_usageConsistencyOnError ... [SKIPPED]
twisted.names.test.test_examples.MultiReverseLookupTests.test_shebang ... [SKIPPED]
twisted.names.test.test_examples.MultiReverseLookupTests.test_usageConsistency ... [SKIPPED]
twisted.names.test.test_examples.MultiReverseLookupTests.test_usageConsistencyOnError ... [SKIPPED]
twisted.names.test.test_examples.TestDnsTests.test_shebang ... [SKIPPED]
twisted.names.test.test_examples.TestDnsTests.test_usageConsistency ... [SKIPPED]
twisted.names.test.test_examples.TestDnsTests.test_usageConsistencyOnError ... [SKIPPED]

Change History (7)

comment:1 Changed 4 years ago by Jean-Paul Calderone

Milestone: Twisted 14.1.0
Type: defectregression

comment:2 Changed 3 years ago by Roberto Polli

Cc: Roberto Polli added
Keywords: review added
Owner: set to Richard Wall

Fixed:

1- if tests can't find example files, raise FailTest instead of SkipTest

2- fixed example directory path

https://github.com/twisted/twisted/pull/39

comment:3 Changed 3 years ago by Richard Wall

Status: newassigned

Reviewing...

comment:4 Changed 3 years ago by Richard Wall

Author: rwall
Branch: branches/names-examples-path-7352

(In [42897]) Branching to names-examples-path-7352.

comment:5 Changed 3 years ago by Richard Wall

Keywords: review removed
Owner: changed from Richard Wall to Roberto Polli
Status: assignednew

Thanks ioggstream

Unfortunately our idea for failing the tests rather than skipping them, doesn't work, because some of the buildbot slaves (the debian builders) run the tests against a packaged version of twisted; where the examples are not installed along side the modules.

So I've reverted that change to SkipTest.

And the tests now pass.

So I'll merge.

comment:6 Changed 3 years ago by Richard Wall

Resolution: fixed
Status: newclosed

(In [42902]) Merge names-examples-path-7352

Author: ioggstream Reviewers: rwall Fixes: #7352

Fix paths to examples in twisted names tests.

comment:7 Changed 2 years ago by hawkowl

Milestone: Twisted 14.1.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.