Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7040 enhancement closed duplicate (duplicate)

Add context manager to assertRaises

Reported by: Adi Roiban Owned by: Adi Roiban
Priority: normal Milestone:
Component: trial Keywords:
Cc: Jonathan Lange Branch:
Author:

Description

Twisted redefines assertRaises and it is not a context-manager anymore

That looks like a bug in the test class, actually. Cf. http://twistedmatrix.com/trac/browser/tags/releases/twisted-13.2.0/twisted/trial/_synctest.py#L313

Change History (3)

comment:1 Changed 4 years ago by DefaultCC Plugin

Cc: Jonathan Lange added

comment:2 Changed 4 years ago by Adi Roiban

Resolution: duplicate
Status: newclosed

Duplicate of #7040

comment:3 Changed 4 years ago by Jean-Paul Calderone

Duplicate of #5339. :)

Note: See TracTickets for help on using tickets.