Opened 4 years ago

Closed 4 years ago

#7030 enhancement closed duplicate (duplicate)

add dev-requirements.txt file to use with virtualenv

Reported by: Chris Wolfe Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: herrwolfe

Description

As a developer new to Twisted, It was a bit unclear to me how I should proceed running Twisted's test suite during development.

It would be beneficial to new developers to be able to run a single command like pip install -r dev-requirements.txt to install all of the projects needed dependencies in a single step. This seems to be the norm amongst other Python projects.

To simplify the development of Twisted using virtual environments I propose that a dev-requirements.txt file be added to the repository. This file would list all requirements needed to be able to run twisted and it's test suite.

This was spawned from a discussion on irc.freenode.net/#twisted-dev at 13:23 CST on 12 March 2014.

Attachments (1)

add-dev-requirements-file-7030-1.patch (205 bytes) - added by Chris Wolfe 4 years ago.
Patch containing the contents of dev-requirements.txt against trunk.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Chris Wolfe

Patch containing the contents of dev-requirements.txt against trunk.

comment:1 Changed 4 years ago by Chris Wolfe

Author: Chris Wolfeherrwolfe

comment:2 Changed 4 years ago by Thijs Triemstra

Keywords: review removed
Resolution: duplicate
Status: newclosed

Thanks for your contribution. This is a duplicate of #6767.

Note: See TracTickets for help on using tickets.