Opened 4 years ago

Closed 4 years ago

#6818 defect closed duplicate (duplicate)

DNS/UDP protocol noise (Twisted 13.1)

Reported by: Bob Novas Owned by:
Priority: normal Milestone:
Component: names Keywords:
Cc: Branch:
Author:

Description

The DNS protocol is very noisy, and near impossible to quiet.

twisted.internet.udp.py, line 117 twisted.internet.udp.py, line 236

I eliminated two other sources of noise by overriding client.Resolver _query() and _connectedProtocol and setting the noisy flag False.

Why are log messages emitted at all by the protocol? I don't really want them and it's trouble to quiet them!

Thanks.

Change History (1)

comment:1 Changed 4 years ago by habnabit

Resolution: duplicate
Status: newclosed

Thanks, but this is a duplicate of #4021.

Note: See TracTickets for help on using tickets.