Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#6791 defect closed duplicate (duplicate)

Issues with Python 3 port of twisted.internet.base

Reported by: Itamar Turner-Trauring Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: garrison Branch:
Author:

Description

Garrison says: "I don't believe that twisted.internet.base is completely ported to Python3. In particular, there are mentions of str and unicode in the file that correspond to Python2 usage."

Change History (5)

comment:1 Changed 4 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

99% confident this is a duplicate of #5968 - and without details, who's to say that's not true?

comment:2 Changed 4 years ago by garrison

Resolution: duplicate
Status: closedreopened

Without details here, or on #5968? The issue is with ReactorBase._checkProcessArgs(), which indeed is related to IReactorProcess, but #5968 makes no mention of fixing IReactorBase or twisted.internet.base.

The plan at wiki:Plan/Python3 claims twisted.internet.base is finished being ported to python3, and that is simply not true. I suppose ticket #6065 was closed because the tests pass, but perhaps this means there is not extensive enough test coverage? The "review" in step 9 of the plan is supposed to catch these string issues and did not, so I think a bug against this is fair.

comment:3 Changed 4 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: reopenedclosed

It will be impossible to port the IReactorProcess implementation without fixing ReactorBase._checkProcessArgs. There's no need for two tickets to track this work.

comment:4 Changed 4 years ago by Jean-Paul Calderone

To be sure no one overlooks this, I've updated the description of #5968 to mention _checkProcessArgs.

comment:5 Changed 4 years ago by garrison

Great, thanks.

Note: See TracTickets for help on using tickets.