Opened 4 years ago

Closed 4 years ago

#6769 defect closed duplicate (duplicate)

TLS doesn't notify when the handshake is done

Reported by: Andy Lutomirski Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

TLSMemoryBIOFactory calls the underlying protocol's connectionMade as soon as it's connected, not after the handshake is complete.

This is bad -- I have a protocol that's a singleton. I need to know when a legitimate client is connected. I shouldn't have connectionMade called (or even be instantiated, I think) until the client has handshaked successfully. (I'm using client certificates.)

Even worse, there doesn't seen to be any notification at all that the handshake has completed successfully.

Change History (1)

comment:1 Changed 4 years ago by habnabit

Resolution: duplicate
Status: newclosed

Thanks for the report, but this is a duplicate of #6024.

Note: See TracTickets for help on using tickets.