Opened 4 years ago

Closed 4 years ago

#6766 enhancement closed duplicate (duplicate)

Support specifying the number of trial jobs via number of CPUs

Reported by: Julian Berman Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Jonathan Lange Branch:
Author:

Description

GNU Parallel (and some other things I think) support a -j+n syntax which sets the number of jobs to be "n + (# of CPUs)". So in particular -j+0 is useful.

It would be nice to be able to pass this to trial -j.

See also https://twistedmatrix.com/trac/ticket/1784#comment:98 where glyph points out that apparently this was dropped without comment from the original implementation where it was spelled -j auto.

Change History (3)

comment:1 Changed 4 years ago by DefaultCC Plugin

Cc: Jonathan Lange added

comment:2 Changed 4 years ago by Julian Berman

Duplicate of #5824.

comment:3 Changed 4 years ago by Julian Berman

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.