Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6522 task closed duplicate (duplicate)

Get rid of _keptErrors in twisted.python.log

Reported by: Wilfredo Sánchez Vega Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch: branches/kept-errors-6522
branch-diff, diff-cov, branch-cov, buildbot
Author: wsanchez

Description

twisted.python.log has a _keptErrors symbol that is private and maintained but not used by anything in that module or any other module in Twisted:

[pucca:~/Developer/Twisted/Twisted/trunk] wsanchez$ xfinds _keptErrors
./twisted/python/log.py:_keptErrors = []
./twisted/python/log.py:                    _keptErrors.append(_stuff)
./twisted/python/log.py:                _keptErrors.append(_stuff)
./twisted/topfiles/ChangeLog.Old:	we're doing _keepErrors, then also add them to _keptErrors.

Die, please.

Change History (2)

comment:1 Changed 5 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Thanks for noting this. Duplicate of #6510 though, recently filed by dreid.

comment:2 Changed 5 years ago by Wilfredo Sánchez Vega

Author: wsanchez
Branch: branches/kept-errors-6522

(In [38451]) Branch for #6522

Note: See TracTickets for help on using tickets.