Opened 5 years ago

Closed 5 years ago

#6376 defect closed duplicate (duplicate)

running the tests with PyCrypto installed, but without pyasn1, results in confusing failures

Reported by: Glyph Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

trial --without-module=pyasn1 twisted results in this:

[ERROR]
Traceback (most recent call last):
  File ".../twisted/plugin.py", line 213, in getPlugins
    adapted = interface(plugin, None)
  File ".../zope/interface/interface.py", line 494, in _call_conform
    return conform(self)
  File ".../twisted/plugin.py", line 68, in __conform__
    return self.load()
  File ".../twisted/plugin.py", line 63, in load
    return namedAny(self.dropin.moduleName + '.' + self.name)
  File ".../twisted/python/_reflectpy3.py", line 279, in namedAny
    obj = getattr(obj, n)
exceptions.AttributeError: 'module' object has no attribute 'theSSHKeyCheckerFactory'

twisted.test.test_strcred.TestAnonymousChecker.testAnonymousAccessSucceeds
twisted.test.test_strcred.TestAnonymousChecker.test_isChecker
twisted.test.test_strcred.TestCheckerOptions.test_createsDictionary
twisted.test.test_strcred.TestCheckerOptions.test_credInterfacesProvidesLists
twisted.test.test_strcred.TestCheckerOptions.test_listDoesNotDisplayDuplicates
twisted.test.test_strcred.TestCheckerOptions.test_displaysListCorrectly
twisted.test.test_strcred.TestCheckerOptions.test_displaysListCorrectly
twisted.test.test_strcred.TestCheckerOptions.test_displaysListCorrectly
twisted.test.test_strcred.TestCheckerOptions.test_invalidAuthError
twisted.test.test_strcred.TestCheckerOptions.test_invalidAuthError
twisted.test.test_strcred.TestCheckerOptions.test_invalidAuthError
twisted.test.test_strcred.TestLimitingInterfaces.test_helpAuthLimitsOutput
twisted.test.test_strcred.TestLimitingInterfaces.test_helpAuthTypeLimitsOutput
twisted.test.test_strcred.TestLimitingInterfaces.test_helpAuthTypeLimitsOutput
twisted.test.test_strcred.TestLimitingInterfaces.test_unsupportedInterfaceError
twisted.test.test_strcred.TestPublicAPI.test_emptyDescription
twisted.test.test_strcred.TestPublicAPI.test_emptyDescription
twisted.test.test_strcred.TestPublicAPI.test_emptyDescription
twisted.test.test_strcred.TestPublicAPI.test_invalidAuthType
twisted.test.test_strcred.TestPublicAPI.test_invalidAuthType
twisted.test.test_strcred.TestPublicAPI.test_invalidAuthType
twisted.test.test_strcred.TestUnixChecker.test_isChecker
twisted.test.test_strcred.TestStrcredFunctions.test_findCheckerFactories
twisted.test.test_strcred.TestStrcredFunctions.test_findCheckerFactories

Change History (2)

comment:1 Changed 5 years ago by Thijs Triemstra

This looks like a duplicate of #5805 (that has almost exactly the same failing tests).

comment:2 Changed 5 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Looks like it. The problem described here also only arises after dropin.cache has been written to reflect pyasn1 (or pycrypto) is available.

Note: See TracTickets for help on using tickets.