Ticket #6317 enhancement closed duplicate

Opened 14 months ago

Last modified 14 months ago

Remove deprecated `twisted.names.root.discoverAuthority`

Reported by: tom.prince Owned by:
Priority: normal Milestone:
Component: names Keywords:
Cc: thijs Branch: branches/remove-discoverAuthority-6317
(diff, github, buildbot, log)
Author: tomprince Launchpad Bug:

Description

It was deprecated in 10.0 and uses deferedGenerator which is being deprecated in #6044.

Change History

1

Changed 14 months ago by tomprince

  • branch set to branches/remove-discoverAuthority-6317
  • branch_author set to tomprince

(In [37170]) Branching to remove-discoverAuthority-6317.

2

Changed 14 months ago by tom.prince

  • keywords review added
  • component changed from core to names

It turns out there was a bunch of other stuff in twisted.names.root deprecated at the same time. Remove them all.

3

Changed 14 months ago by thijs

  • cc thijs added

This is a duplicate of #5564 where I removed the deprecated code but exarkun mentioned then (5 months ago now) that it shouldn't be removed yet.

4

Changed 14 months ago by tom.prince

  • status changed from new to closed
  • keywords review removed
  • resolution set to duplicate
Note: See TracTickets for help on using tickets.