Ticket #6308 enhancement closed duplicate

Opened 14 months ago

Last modified 14 months ago

TLS endpoint that wraps another endpoint

Reported by: itamar Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

The current way of doing SSL with endpoints involves using listenSSL/connectSSL. This means you need one for each of TCPv4 and TCPv6, and we'll need one for the hostname endpoint too. And, you can't use it with e.g. a SOCKS endpoint.

Better would be an endpoint (or maybe I mean pair of endpoints, one client one server) that wrap an existing endpoint. Ideally this wouldn't even call transport.startTLS, but rather use the TLS protocol implementation directly.

Change History

1

Changed 14 months ago by tom.prince

  • status changed from new to closed
  • resolution set to duplicate

This appears to be a duplicate of #5642.

Note: See TracTickets for help on using tickets.