Opened 5 years ago

Closed 4 years ago

#6305 defect closed duplicate (duplicate)

t.c.s.c.SSHChannel.getHost() and getPeer() raises error

Reported by: Stefan Owned by:
Priority: normal Milestone:
Component: conch Keywords:
Cc: z3p Branch:
Author:

Description

t.c.s.c.SSHChannel.getHost() and getPeer() on a SSHChannel backed by a TCP connection cause the following error:

TypeError: can only concatenate tuple (not "SSHTransportAddress") to tuple

Caused by the line: return('SSH', )+self.conn.transport.getPeer()

self.conn.transport.getPeer() returns a perfectly sensible and useful SSHTransportAddress that wraps the IPv4Address.

I suggest to either just return the SSHTransportAddress or to introduce another wrapper SSHChannelAddress.

Change History (2)

comment:1 Changed 5 years ago by DefaultCC Plugin

Cc: z3p added

comment:2 Changed 4 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Thanks. Sadly, duplicate of #5999.

Note: See TracTickets for help on using tickets.