Opened 5 years ago

Closed 5 years ago

#6248 defect closed duplicate (duplicate)

twisted.python.test.test_fakepwd.PwdModuleTests.test_noSuchUID failing on fedora buildbot

Reported by: Glyph Owned by: Glyph
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

twisted.python.test.test_fakepwd.PwdModuleTests.test_noSuchUID assumes that it can pass a negative number as a known-invalid UID and get an error result. But as this build failure shows, on RHEL6/x64, this is an OverflowError instead.

There is also a possibly relevant, related Python bug.

Change History (1)

comment:1 Changed 5 years ago by Glyph

Resolution: duplicate
Status: newclosed

Duplicate of #6201

Note: See TracTickets for help on using tickets.