Opened 5 years ago

Closed 5 years ago

#6214 defect closed duplicate (duplicate)

Race condition in twisted.test.test_threadpool.RaceConditionTestCase.test_synchronization

Reported by: Jordan Hagan Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description (last modified by Jean-Paul Calderone)

There seems to be a race condition somewhere in this TestCase. I would guess that it might be a threading issue as the test runner never completes when encountered:

[FAIL]
Traceback (most recent call last):
  File "/home/fs/code/twisted2/twisted/test/test_threadpool.py", line 512, in test_synchronization
    self.fail("Actions not synchronized")
twisted.trial.unittest.FailTest: Actions not synchronized

twisted.test.test_threadpool.RaceConditionTestCase.test_synchronization
-------------------------------------------------------------------------------
Ran 15 tests in 5.059s

FAILED (failures=1, successes=14)

To reproduce:

while true; do python bin/trial twisted.test.test_threadpool.RaceConditionTestCase; done

Environment:

Python 2.7.3

argparse==1.2.1
distribute==0.6.27
wsgiref==0.1.2
zope.interface==4.0.2

Subversion revision: 36611

Change History (1)

comment:1 Changed 5 years ago by Jean-Paul Calderone

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #2673

Note: See TracTickets for help on using tickets.