Opened 5 years ago

Closed 5 years ago

#6193 enhancement closed duplicate (duplicate)

It's not possible to figure out final URL of RedirectAgent responses

Reported by: Itamar Turner-Trauring Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: jknight Branch:
Author:

Description

A response returned from RedirectAgent may well be for a different URL than the one requested. It would be useful to have some way of knowing the final URL that the response is for.

This may be an instance of a more general issue: there's no good way to know for a response all the parameters of the corresponding request. Perhaps Response objects should have requestMethod, requestURL and requestHeaders attributes.

Change History (2)

comment:1 Changed 5 years ago by DefaultCC Plugin

Cc: jknight added

comment:2 Changed 5 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #5435

Note: See TracTickets for help on using tickets.