Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#6181 defect closed fixed (fixed)

`content` attribute of HTTP requests is not documented anywhere

Reported by: Itamar Turner-Trauring Owned by: Jean-Paul Calderone
Priority: normal Milestone:
Component: web Keywords: documentation
Cc: jknight Branch: branches/request.content-6181
branch-diff, diff-cov, branch-cov, buildbot
Author: exarkun

Description

If you want to access the body of e.g. a POST, you do so with content attribute of the twisted.web.server.Request instance. This attribute is not, however, documented in the API docs, nor is it mentioned in the "Using Twisted Web" or "Twisted Web in 60 Seconds" howtos.

Change History (8)

comment:1 Changed 5 years ago by DefaultCC Plugin

Cc: jknight added

comment:2 Changed 4 years ago by Glyph

#6195 was a duplicate of this.

comment:3 Changed 4 years ago by Jean-Paul Calderone

Author: exarkun
Branch: branches/request.content-6181

(In [36459]) Branching to 'request.content-6181'

comment:4 Changed 4 years ago by Jean-Paul Calderone

Keywords: review added

comment:5 Changed 4 years ago by therve

Keywords: review removed
Owner: set to Jean-Paul Calderone
  • +<li><a href="other-request-bodies.xhtml">Other Request Bodies</a></li>
    

I don't think we should capitalize this, "Other request bodies" is fine.

Please merge!

comment:6 Changed 4 years ago by Jean-Paul Calderone

(In [36483]) Un-titlecase the title link, for local consistency

refs #6181

comment:7 Changed 4 years ago by Jean-Paul Calderone

Resolution: fixed
Status: newclosed

(In [36484]) Merge request.content-6181

Author: exarkun Reviewer: therve Fixes: #6181

Add documentation for the content attribute to twisted.web.iweb.IRequest. The request object has always had this attribute.

comment:8 Changed 4 years ago by Jean-Paul Calderone

This was a duplicate of #4252.

Note: See TracTickets for help on using tickets.