Opened 2 years ago

Closed 2 years ago

#6174 enhancement closed duplicate (duplicate)

trial should warn when there are still running threads in the reactor threadPool

Reported by: tom.prince Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: jml Branch:
Author: Launchpad Bug:

Description

The following code demonstrates that it doesn't.

from twisted.trial.unittest import TestCase
from twisted.internet import reactor, defer
from time import sleep

class Test(TestCase):
    def test_test(self):
        d = defer.Deferred()
        def thd():
            sleep(0.1)
            reactor.callFromThread(d.callback, None)
            sleep(1)
            print "HERE"
        reactor.callInThread(thd)
        return d

Change History (2)

comment:1 Changed 2 years ago by DefaultCC Plugin

  • Cc jml added

comment:2 Changed 2 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #962

Note: See TracTickets for help on using tickets.