Opened 5 years ago

Closed 5 years ago

#6150 enhancement closed duplicate (duplicate)

twisted.python.test.test_deprecate.TestDeprecationWarnings depends on execution order

Reported by: Julian Berman Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

test_deprecatedUpdatesDocstring tests that the docstring of dummyCallable is mutated, but later tests (test_deprecatedReplacement and test_deprecatedReplacementWithCallable) make assertions on the docstring.

The tests pass because the default ordering puts those two tests first, but the failures show up after running the tests with --order=toptobottom from #5787.

Change History (1)

comment:1 Changed 5 years ago by Julian Berman

Resolution: duplicate
Status: newclosed

Duplicate of #5197.

Note: See TracTickets for help on using tickets.