Opened 22 months ago

Closed 16 months ago

Last modified 16 months ago

#6143 enhancement closed duplicate (duplicate)

Add an option for dropping into a debugger only after an error/failure

Reported by: Julian Owned by: mayank
Priority: normal Milestone:
Component: trial Keywords: easy
Cc: jml Branch:
Author: Launchpad Bug:

Description

See nosetests --pdb and --pdb-failures and py.test --pdb which both do it this way, rather than needing to step through test runner code.

I personally don't really use them independently of one another (like nose has it) so IMHO just a single option for dropping in either case into a debugger would be fine.

Since --debug is taken, I can't think of a great name immediately. --debug-non-successes is kinda long.

Change History (6)

comment:1 Changed 22 months ago by DefaultCC Plugin

  • Cc jml added

comment:2 Changed 16 months ago by Julian

#2230 was a duplicate of this. When this lands, we should make sure the desired behavior there re: --until-failure works properly.

comment:3 Changed 16 months ago by Julian

  • Keywords easy added

comment:4 Changed 16 months ago by mayank

  • Owner set to mayank
  • Status changed from new to assigned

comment:5 follow-up: Changed 16 months ago by glyph

  • Resolution set to duplicate
  • Status changed from assigned to closed

Since #2330 is the much older ticket here, I'm closing this one as a duplicate instead.

comment:6 in reply to: ↑ 5 Changed 16 months ago by glyph

Replying to glyph:

Since #2330 is the much older ticket here, I'm closing this one as a duplicate instead.

Ahem. #2230.

Note: See TracTickets for help on using tickets.