Opened 14 years ago

Closed 7 years ago

#614 defect closed duplicate (duplicate)

IReadDescriptor and IWriteDescriptor are missing some methods which the reactor requires of such objects

Reported by: Jean-Paul Calderone Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: Glyph, radix, Jean-Paul Calderone, itamarst, therve, Thijs Triemstra, zseil Branch:
Author:

Description


Change History (9)

comment:1 Changed 14 years ago by Jean-Paul Calderone

The reactor calls other methods on objects which supposedly conform to these
interfaces.  For example, connectionLost().

comment:2 Changed 11 years ago by therve

Cc: therve added
Component: conch

It seems some things have been corrected, at least for connectionLost. Is there any missing methods?

comment:3 Changed 11 years ago by therve

Component: conchcore

comment:4 Changed 9 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

comment:5 Changed 9 years ago by Jean-Paul Calderone

Summary: IReadDescriptor and IWriteDescriptor are incompleteIReadDescriptor and IWriteDescriptor are missing some methods which the reactor requires of such objects

comment:6 Changed 8 years ago by Glyph

The big one that comes to mind for me is fileno().

comment:7 Changed 7 years ago by zseil

Cc: zseil added

IReadDescriptor and IWriteDescriptor inherit the fileno() and connectionLost() methods from IFileDescriptor, and logPrefix() method from ILoggingContext. The only other method that the reactors seem to call is readConnectionLost() but those calls are guarded by IHalfCloseableDescriptor.providedBy(fd). Is there anything else missing?

comment:8 Changed 7 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Thanks for looking into this, zseil. #1272 was apparently a duplicate of this, and has since been resolved by r19854.

comment:9 Changed 7 years ago by <automation>

Owner: itamarst deleted
Note: See TracTickets for help on using tickets.