Opened 5 years ago

Closed 2 years ago

#5968 enhancement closed fixed (fixed)

Port POSIX `IReactorProcess` implementation to Python 3

Reported by: Jean-Paul Calderone Owned by:
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: garrison Branch:
Author:

Description (last modified by Jean-Paul Calderone)

This involves a few different things:

  • The primary implementation module, twisted.internet.process
  • At least some parts of twisted.internet.posixbase (spawnProcess definition) and twisted.internet.base (_checkProcessArgs)
  • Get twisted.internet.test.test_process to pass
  • Get twisted.test.test_process to pass
  • Enable process cleanup on Python 3 in twisted.internet.test.reactormixins.

Change History (6)

comment:1 Changed 5 years ago by Itamar Turner-Trauring

Milestone: Python 3.3 MinimalPython-3.x

To make the porting simpler, we might want to do parts of it separately, e.g. only twisted.internet.process in #5987.

comment:2 Changed 4 years ago by Jean-Paul Calderone

#6791 was a duplicate of this.

comment:3 Changed 4 years ago by Jean-Paul Calderone

Description: modified (diff)

comment:4 Changed 4 years ago by garrison

Cc: garrison added

comment:5 Changed 4 years ago by Jean-Paul Calderone

#6983 was a duplicate of this.

comment:6 Changed 2 years ago by hawkowl

Resolution: fixed
Status: newclosed

I believe this is fixed now by #5987.

Note: See TracTickets for help on using tickets.