Ticket #5901 enhancement closed fixed

Opened 20 months ago

Last modified 20 months ago

Change trial's assert method implementation to stop emphasizing the `fail` variations

Reported by: exarkun Owned by: exarkun
Priority: normal Milestone:
Component: trial Keywords:
Cc: jml Branch: branches/trial-assert-5901
(diff, github, buildbot, log)
Author: exarkun Launchpad Bug:


Everyone is switching to the assert spellings,  including us.

Change History


Changed 20 months ago by DefaultCC Plugin

  • cc jml added


Changed 20 months ago by exarkun

  • branch set to branches/trial-assert-5901
  • branch_author set to exarkun

(In [35336]) Branching to 'trial-assert-5901'


Changed 20 months ago by exarkun

(In [35337]) Rename the assertion methods to start with "assert" and make "fail" be the aliases.

refs #5901


Changed 20 months ago by exarkun

  • keywords review added
  • owner exarkun deleted


Changed 20 months ago by Julian

  • owner set to Julian


Changed 20 months ago by Julian

  • keywords review removed
  • owner changed from Julian to exarkun

Looks good to me. Only thing worth pointing out that I see is that assertWarns's def line will fit within 79 chars now.

Also, assertNotIsInstance's docstring is wrong. You're not changing that, so I guess that deserves another ticket if you don't want to fix it while you're here, or if you'd prefer that anyhow. The reason I mention it is that now that the assertion methods are defined using positive language, perhaps all of the docstrings might be clearer if they used that too so that you don't need any mental gymnastics to read them. That can go in another ticket too I guess if that's something reasonable sounding.


Changed 20 months ago by exarkun

(In [35347]) Fix an incorrect negation in assertNotIsInstance

refs #5901


Changed 20 months ago by exarkun

  • status changed from new to closed
  • resolution set to fixed

(In [35348]) Merge trial-assert-5901

Author: exarkun Reviewer: Julian Fixes: #5901

Change trial's implementation of assertion methods so that they are named following the "assertXYZ" convention rather than the "failXYZ" convention.

Note: See TracTickets for help on using tickets.