Opened 2 years ago

Closed 2 years ago

#5892 defect closed duplicate (duplicate)

dirty reactor errors in test_endpoints

Reported by: glyph Owned by: ashfall
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

These happened for me in a Windows VM but I suspect they indicate a race condition on other platforms too:

[ERROR]
Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
DelayedCalls: (set twisted.internet.base.DelayedCall.debug = True to debug)
<DelayedCall 0x9fb9588 [0.0999999046326s] called=0 cancelled=0 StandardIO._pollE
vent()>

twisted.internet.test.test_endpoints.StandardIOEndpointsTestCase.test_address
===============================================================================
[ERROR]
Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
DelayedCalls: (set twisted.internet.base.DelayedCall.debug = True to debug)
<DelayedCall 0x9fb7908 [0.0999999046326s] called=0 cancelled=0 StandardIO._pollE
vent()>

twisted.internet.test.test_endpoints.StandardIOEndpointsTestCase.test_protocol
===============================================================================
[ERROR]
Traceback (most recent call last):
Failure: twisted.trial.util.DirtyReactorAggregateError: Reactor was unclean.
DelayedCalls: (set twisted.internet.base.DelayedCall.debug = True to debug)
<DelayedCall 0x9fc1688 [0.0999999046326s] called=0 cancelled=0 StandardIO._pollE
vent()>

twisted.internet.test.test_endpoints.StandardIOEndpointsTestCase.test_standardIO
Instance
===============================================================================

Change History (1)

comment:1 Changed 2 years ago by ashfall

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #5730.

Note: See TracTickets for help on using tickets.