Opened 2 years ago

Closed 23 months ago

#5888 enhancement closed duplicate (duplicate)

Twisted Words examples: Add documentation inside each example

Reported by: luper Owned by: luper
Priority: low Milestone:
Component: words Keywords: easy documentation
Cc: ralphm Branch:
Author: Launchpad Bug:

Description

http://twistedmatrix.com/documents/current/words/examples/index.html

Add documentation inside each example describing how to run it and what it does
See the comment block at the top of minchat.py for an example

Attachments (2)

Ticket5888TwistedWordsExamplesAddDocumentation.patch (3.9 KB) - added by anitgen 23 months ago.
I have added docstrings with To run script descriptions
Ticket5888TwistedWordsExamplesAddDocumentationSecondTry.patch (3.3 KB) - added by anitgen 23 months ago.
I updated the trunk first then created this patch. This is my second try with the updated trunk.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 2 years ago by DefaultCC Plugin

  • Cc ralphm added

comment:2 Changed 2 years ago by luper

  • Owner set to luper
  • Status changed from new to assigned

comment:3 Changed 2 years ago by luper

  • Keywords easy added

comment:4 Changed 2 years ago by thijs

  • Keywords documentation added

Changed 23 months ago by anitgen

I have added docstrings with To run script descriptions

Changed 23 months ago by anitgen

I updated the trunk first then created this patch. This is my second try with the updated trunk.

comment:5 Changed 23 months ago by ashfall

  • Keywords changed from easy, documentation to easy documentation
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #5589, attaching the patch to #5589.

anitgen, Thanks for looking into the ticket. Note that once you submit a patch, you need to add the "review" keyword to indicate that someone should review your changes (might help if you read Twisted's ReviewProcess). Also, please add a news fragment along with your patch.

Note: See TracTickets for help on using tickets.