Opened 10 years ago

Last modified 10 years ago

#588 defect closed fixed (fixed)

tksupport raises bogus error when Tk() object destroyed

Reported by: edsuom Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: itamarst, edsuom, miket Branch:
Author: Launchpad Bug:

Description


Attachments (1)

tksupport.py.diff (197 bytes) - added by edsuom 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by edsuom

comment:1 Changed 10 years ago by edsuom

Theres' currently no clean way to "uninstall" a Tk() root object that's been
installed with tksupport.install(). Doing a root.destroy() raises an error
because tksupport._guiUpdate() tries to do a widget.update() on the destroyed
object.

See attached patch for a simple fix to this.

comment:2 Changed 10 years ago by miket

Thanks to edsuom for this patch. I have confirmed that it solves the described
problem. May we please integrate it into the repository?

comment:3 Changed 10 years ago by itamarst

I added an uninstall() method to tksupport in HEAD r12599. Please reopen if this
insufficient.

comment:4 Changed 4 years ago by <automation>

  • Owner itamarst deleted
Note: See TracTickets for help on using tickets.