Opened 2 years ago

Closed 16 months ago

#5870 enhancement closed duplicate (duplicate)

Make a string parser interface for client endpoints that takes the reactor as a parameter in its signature

Reported by: ashfall Owned by: ashfall
Priority: normal Milestone:
Component: core Keywords: endpoint
Cc: Branch:
Author: Launchpad Bug:

Description

At present, IStreamClientEndpointStringParser.parseStreamClient doesn't take the reactor as a parameter, which is bad.
As a result, even though endpoints.clientFromString needs a reactor to be passed as a parameter, it cannot pass it on to string description plugins for client endpoints, and we end up having to use a global reactor in the plugin, which is bad too.

We need a new interface with the correct signature defined, a new plugin interface to go with it, the plugin loader updated to load that new kind of plugin and call its method correctly, deprecation warnings for use of the old interface, and the existing plugins/parser in Twisted to be ported to the new interface.

Can/should probably be split into smaller tickets.

Change History (3)

comment:1 Changed 2 years ago by ashfall

  • Summary changed from Make a string parser interface for client endpoints that takes the reactor as a parameter in it's signature to Make a string parser interface for client endpoints that takes the reactor as a parameter in its signature

comment:2 Changed 16 months ago by rwall

Duplicate of #5069

comment:3 Changed 16 months ago by rwall

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.