Opened 2 years ago

Closed 2 years ago

#5862 defect closed worksforme (worksforme)

The processing time of http quest sent to reactor.listenSSL() is 6x slower in 11.1 than in 10.1.

Reported by: pwp Owned by: pwp
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

The processing time of http quest sent to reactor.listenSSL() is 6x slower in 11.1 than in 10.1.
An easy profiling points to the change to use TLS as default way of inter-communication.
Is there a way to disable this behavior?

Also does 10.1 works with python 2.7? We were trying to downgrade twisted to v10, but it requires python 2.6 (we have 2.7 installed in ubuntu 12). Is there any issue with twisted 10 working with python 2.7?

Change History (5)

comment:1 Changed 2 years ago by itamar

  • Keywords TLS listenSSL removed
  • Milestone regular-releases deleted
  1. What version pyOpenSSL are using? If pyOpenSSL is >= 0.10, Twisted will use the code in twisted.internet._newtls, older versions use twisted.internet._oldtls (which is equivalent to what older versions would use).
  2. How are you measuring processing time?

comment:2 Changed 2 years ago by exarkun

  • Priority changed from high to normal

Also note that "SSL" and "TLS" are the same thing. An easy profiling points to the change to use TLS as default way of inter-communication doesn't make sense as an explanation.

comment:3 Changed 2 years ago by glyph

For what it's worth, our benchmark of SSL throughput has shown nothing but improvement for the last 1000 revisions. A really good next step for this bug would be to develop a meaningful benchmark which could demonstrate this slowdown, so that we could address it in a measurable way.

comment:4 Changed 2 years ago by glyph

  • Owner set to pwp

comment:5 Changed 2 years ago by glyph

  • Resolution set to worksforme
  • Status changed from new to closed

pwp, since we have no way of reproducing your results, and both our official benchmarks and my personal, informal testing indicates effectively the opposite bug, I'm going to close this so that it doesn't sit around in an ambiguous state forever. However, don't take this to mean that we don't take your problem seriously. If you can answer Itamar's questions and provide us with enough information to reproduce the problem that you're seeing, please add a comment with your answers and re-open the ticket.

Note: See TracTickets for help on using tickets.