Opened 4 years ago

Closed 11 months ago

#5861 enhancement closed fixed (fixed)

Use Python's built-in initgroups always

Reported by: itamar Owned by: hawkowl
Priority: normal Milestone: EndOfLifePython2.6
Component: core Keywords:
Cc: Branch: branches/less-c-initgroups-5861
branch-diff, diff-cov, branch-cov, buildbot
Author: hawkowl

Description

Python 2.7 and 3.3 include os.initgroups, which we can use instead of building our own C extension.

Change History (11)

comment:1 Changed 4 years ago by itamar

  • Milestone changed from Python-3.x to Python 3.3 Minimal

Adding to minimal python 3.3 milestone since used by process.

comment:2 Changed 4 years ago by vperic

Duplicate of #4920? (and yes, I know that ticket is assigned to me - I got stuck when exarkun asked me to write tests and I didn't know how)

BTW, what is this new "Python 3.3 Minimal" milestone? Seems to be relevant to my project (such as it is), but I haven't managed to find any discussion anywhere about it.

comment:3 Changed 4 years ago by itamar

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4920, yes. See http://twistedmatrix.com/trac/wiki/Plan/Python3 for details.

comment:4 Changed 16 months ago by hawkowl

  • Milestone changed from Python 3.3 Minimal to EndOfLifePython2.6

This is a 2.6 thing.

comment:5 Changed 16 months ago by hawkowl

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Bah this actually wasn't open. But rather than file another duplicate, might as well use this one!

comment:6 Changed 11 months ago by hawkowl

  • Author set to hawkowl
  • Branch set to branches/less-c-initgroups-5861

(In [45634]) Branching to less-c-initgroups-5861.

comment:7 Changed 11 months ago by hawkowl

  • Keywords review added

Okay! Removed the old _initgroups.c, and simplified the tests considerably.

Please review.

comment:8 Changed 11 months ago by adiroiban

  • Keywords review removed
  • Owner set to hawkowl
  • Status changed from reopened to new

Please add a bit more details to the scope and changes to this branch.

So with this change we drop support for python 2.6 ?

Why was the _initgroups.c remove.

From what I can see the code from trunk was already using the builting initgroups when available.

comment:9 Changed 11 months ago by hawkowl

  • Keywords review added
  • Owner hawkowl deleted
  • Summary changed from Use Python's built-in initgroups when available to Use Python's built-in initgroups always

Hi Adi,

We've dropped support for 2.6 already officially (see last release announcement), this just cleans up some things that are not required.

_initgroups.c is removed because it was only required for 2.6 support -- it is merged into stdlib now. I've altered the ticket slightly.

comment:10 Changed 11 months ago by adiroiban

  • Keywords review removed
  • Owner set to hawkowl

There is one error which I think can be fixed

************* Module twisted.python.util
W9204:644,4:initgroups: Missing epytext markup @return for return value

please fix and merge.

thanks!

comment:11 Changed 11 months ago by hawkowl

  • Resolution set to fixed
  • Status changed from new to closed

(In [45662]) Merge less-c-initgroups-5861: Use Python's built-in initgroups always

Author: hawkowl Reviewer: adiroiban Fixes: #5861

Note: See TracTickets for help on using tickets.