Opened 2 years ago

Closed 2 years ago

#5829 enhancement closed duplicate (duplicate)

Replace DictMixin in twisted.web.http_headers with MutableMapping

Reported by: vperic Owned by:
Priority: normal Milestone: Python-3.x
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

In Python 3, DictMixin is no longer provided and should be replaced with MutableMapping (which is available in Python 2.6+). This involves, at least, defining a len method for the _DictHeaders class.

./twisted/web/http_headers.py:10:from UserDict import DictMixin

Change History (1)

comment:1 Changed 2 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

#6080 was a duplicate of this, but I didn't notice 'til I was just about done. Closing this as the duplicate instead.

Note: See TracTickets for help on using tickets.