Opened 5 years ago

Closed 5 years ago

#5772 enhancement closed duplicate (duplicate)

Request Timeout for web.client.Agent

Reported by: Tobias Oberstein Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: jknight Branch:
Author:

Description

Agent should have an option to set the request timeout.

Currently, the old getPage has

  • option to set request timeout
  • no option to set connectionTimeout
  • no persistent connection pool

and Agent has

  • no option to set request timeout
  • option to set connectionTimeout
  • persistent connection pool

So Agent is lacking behind getPage wrt to request timeout.

The attached patch adds a request timeout option. When the timeout hits, the request fails with twisted.web._newclient.ResponseNeverReceived.

The request timeout is for the whole request, that is setup as soon as the request has been started to write to the transport. It is not a response-only timeout that would only be started when the producer has finished producing and then timeout for receiving the response.

Change History (2)

comment:1 Changed 5 years ago by DefaultCC Plugin

Cc: jknight added

comment:2 Changed 5 years ago by therve

Resolution: duplicate
Status: newclosed

Duplicate of #5773.

Note: See TracTickets for help on using tickets.