Opened 2 years ago

Closed 2 years ago

#5762 defect closed duplicate (duplicate)

Conch logs too much stuff, much of it not interesting

Reported by: exarkun Owned by:
Priority: normal Milestone:
Component: conch Keywords: logging
Cc: z3p Branch:
Author: Launchpad Bug:

Description (last modified by exarkun)

Here's what Conch logs during the process of connecting, authenticating (successfully on the first try, otherwise there'd be more), and executing one command:

2012-07-10 15:19:17+0000 [_CommandTransport,client] kex alg, key alg: diffie-hellman-group-exchange-sha1 ssh-rsa
2012-07-10 15:19:17+0000 [_CommandTransport,client] outgoing: aes256-ctr hmac-sha1 none
2012-07-10 15:19:17+0000 [_CommandTransport,client] incoming: aes256-ctr hmac-sha1 none
2012-07-10 15:19:17+0000 [_CommandTransport,client] REVERSE
2012-07-10 15:19:17+0000 [_CommandTransport,client] NEW KEYS
2012-07-10 15:19:17+0000 [_CommandTransport,client] starting service ssh-userauth
2012-07-10 15:19:17+0000 [_CommandTransport,client] using agent
2012-07-10 15:04:46+0000 [SSHAgentClient,client] got 1 public keys
2012-07-10 15:04:46+0000 [SSHService ssh-userauth on _CommandTransport,client] can continue with: ['publickey', 'keyboard-interactive']
2012-07-10 15:04:46+0000 [SSHService ssh-userauth on _CommandTransport,client] ['/path/to/key']
2012-07-10 15:04:46+0000 [SSHService ssh-userauth on _CommandTransport,client] /path/to/key
2012-07-10 15:04:46+0000 [SSHService ssh-userauth on _CommandTransport,client] using key of type RSA
2012-07-10 15:04:47+0000 [SSHService ssh-userauth on _CommandTransport,client] starting service ssh-connection
2012-07-10 15:04:47+0000 [SSHService ssh-userauth on _CommandTransport,client] opening channel 0 with 131072 32768
2012-07-10 15:04:47+0000 [SSHChannel session (0) on SSHService ssh-connection on _CommandTransport,client] sending request exec
2012-07-10 15:04:47+0000 [SSHChannel session (0) on SSHService ssh-connection on _CommandTransport,client] remote eof
2012-07-10 15:04:47+0000 [SSHChannel session (0) on SSHService ssh-connection on _CommandTransport,client] unhandled request for exit-status
2012-07-10 15:04:47+0000 [SSHChannel session (0) on SSHService ssh-connection on _CommandTransport,client] remote close
2012-07-10 15:04:47+0000 [SSHChannel session (0) on SSHService ssh-connection on _CommandTransport,client] sending close 0

This is largely irrelevant. Several lines are redundant, several are mysterious and unexplained, some reflect obscure or unimportant internals ("remote eof"? "sending close 0"? Imagine if Protocol.connectionLost or ITransport.loseConnection logged whenever it ran).

Many of these should just be removed. Others should be converted to structured log events that don't have a message by default.

A good first goal to aim for is to have nothing written to the log by the default log observer in the common (success) case.

Change History (5)

comment:1 Changed 2 years ago by DefaultCC Plugin

  • Cc z3p added

comment:2 Changed 2 years ago by exarkun

  • Description modified (diff)

comment:3 Changed 2 years ago by mmoya

  • Cc mmoya@… added

comment:4 Changed 2 years ago by mmoya

  • Cc mmoya@… removed

Seems a duplicate of #5508.

comment:5 Changed 2 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Yep, thanks.

Note: See TracTickets for help on using tickets.