Raise the minimum required version of zope.interface to 3.6.0
|Reported by:||Itamar Turner-Trauring||Owned by:||Itamar Turner-Trauring|
|Cc:||Vladimir Perić, Thijs Triemstra||Branch:||
branch-diff, diff-cov, branch-cov, buildbot
Description (last modified by )
As mentioned in http://pypi.python.org/pypi/zope.interface/4.0.0, newer versions of zope.interface give deprecation warning for
implements(), which is used widely by Twisted. This was done in order to support Python 3; the newer version is a class decorator.
As part of Python 3 support we should probably switch to the new style. It was added in zope.interface 3.6, in 2010, so switching completely doesn't seem like an issue: http://pypi.python.org/pypi/zope.interface/3.6.0#id5
Using class decorators shouldn't be a problem post-12.1, since we'll have dropped Python 2.5 support by then (#5553).
We should ensure Twisted mentions it requires zope.interface 3.6 in the appropriate places (import time, dependency documentation).
Change History (31)
comment:7 Changed 4 years ago by
|Summary:||zope.interface 4.0 causes DeprecationWarning for implements() → Raise the minimum required version of zope.interface to 3.6.0|